LG Optimus F3 Forum

Root [Virgin Mobile/Sprint] "Sim card is invalid."

[​IMG]

So I've been getting this message.

Context: Optimus F3 (obviously), was rooted. After cleaning the davlik cache this past Friday I rebooted... and had no phone service afterwards. No bars at all. On my lock screen I get a "Sim card is invalid" error.

I tried a factory reset, but the problem remains... my phone has no phone service. Repeated calls to VM customer support have been pretty useless so far. My assumption has been I just need a new UICC card, but I'm really not sure.

So... to those of you that know far more about these things than me: Is there any possibility I erased something that would cause this type of problem? Anything you can think of at all?

If not, no worries. Figured it's worth asking before I waste more time listening to VM's terrible hold music.

Thanks for your time.
 

Related:

#1 thatwasawkward, Nov 18, 2013
Well you could try the unbrick thread and reflash it.
 
#2 HaTrEd360, Nov 18, 2013
That's exactly the kind of obvious-to-you-but-not-me answer I was hoping for. Will try that, thanks.
 
#3 thatwasawkward, Nov 18, 2013
Just to follow up in case anyone is interested...

I successfully followed the instructions in the unbrick thread, but it did not solve my problem. Still no phone service or data.

I called VM and they sent me a new UICC card. Still no phone service or data.

Basically it now seems clear that the problem is the phone's identity information. The ESN and MEID values have been completely zeroed out -- I honestly have no idea how -- and based on what I've been reading that would likely cause the problems I'm now having.

ALSO, it appears it's pretty much impossible to repair those values. I've tried several of the methods floating around the interwebs with no success. Mainly it seems like nobody has the drivers for this particular phone, I assume because it's fairly new. So frustrating.

To get to the point: Might anyone here have any experience repairing the ID values on the Optimus F3?

Many thanks once again.
 
#4 thatwasawkward, Nov 23, 2013
You might reach out to sammyz to see if he can help.


Might also take a look at the OUDHS website.
 
#5 bkttk2, Nov 23, 2013
I had the same problem. My solution was to go into setting, system updates and attempt to update everything. I don't have any idea if that was the fix or if it was just luck. It took 2 or 3 shut down, reboot cycles to show that it was fixed.
 
#6 KJRob, Dec 8, 2013
My phone just started doing the same thing after the battery died. I charged it but when I turned it back on it said "invalid sim card"? Is there a solution for this issue?
 
#7 crowscrow, Jan 8, 2014
I assumed the thing in the sin card slot was fake. I didn't think sprint was gsm.
 
#8 manymarius73, Jan 9, 2014
The Sim card in this phone is just a UICC Card. Which is for your LTE. Take it out and you just lose 4G LTE, lol. All that happened was that your phone inactivated it self basically. Rebooting a few times solved that tho. I've seen it happen before.
 
#9 HaTrEd360, Jan 9, 2014