Samsung Galaxy S3 Forum

Root [Verizon] ODIN can't see my phone

I am attempting to root my phone using the guide on the XDA forums site (linked from this site). I can put my phone into Odin download mode fine, but whenever I plug the cable in and run the Odin application, nothing shows up under ID:COM. I can hear the "ding" that Windows XP makes when a USB device is plugged in, but Odin never sees it.

If I boot the phone normal and connect the cable, I can look at the card on the phone and transfer files, etc. But nothing at all when the phone is in Odin download mode. I only have access to 1 Windows machine, which is my work PC. I run predominantly Ubuntu Linux at home.

Am I stuck here or is there another way? I have also tried to use Oracle VirtualBox with an XP virtual machine, but that gives me a Blue Screen of Death every time I try to put the first boot chain file on.

Thanks,
Harry
 

Related:

#1 hdevine, Jun 21, 2013
have you installed the drivers and turned on usb debugging
 
#2 kevindroid, Jun 21, 2013
Yes, the drivers are installed, as I can access the SD cards on the phone when its powered up normally. How do I turn on USB debugging when I'm in the Odin download mode?
 
#3 hdevine, Jun 21, 2013
You would have to turn on USB Debugging on whilst booted up.
It should be in the Developer settings :)
 
#4 Mikestony, Jun 21, 2013
OK, I found that in Developer settings, but will that carry over and be available when I reboot the phone into Odin mode (Volume Down/Home/Power)?
 
#5 hdevine, Jun 21, 2013
Yes it will ;)
 
#6 Mikestony, Jun 21, 2013
OK, how is it available? I have the same thing going on. Odin 3.07 is blank for ID:COM when the phone is plugged in. The screen on the phone has the green Android robot in the middle saying "Downloading... Do not turn off target!!". The top left of it looks like:

ODIN MODE (in red)
PRODUCT NAME: SCH-I535
CUSTOM BINARY DOWNLOAD: No
CURRENT BINARY: Samsung Official
SYSTEM STATUS: Official
QUALCOMM SECUREBOOT: ENABLE (in gray)

Ideas and/or thoughts?
Harry
 
#7 hdevine, Jun 21, 2013
Only suggestion I have @ this point is to try a different cable, possibly the samsung one that came with the device . . .

Edit . . .

connect the phone to the pc in normal (phone on) mode. Then, pull down the notification window(swipe downward from the top of the phone`s screen) & the connection status should say "connected as a media device". If it says "connected as an installer", change it to media device & re-try Odin again . . .
 
#8 TALONTRAX, Jun 21, 2013
I'll try that, but the cable I have is the Samsung cable that came with it. My luck is its an XP usb think since XP is so old.

Thanks!
Harry
 
#9 hdevine, Jun 21, 2013
Sorry, I should have clarified...when you enable usb debugging, it will stay enabled ("available" if you will) when in download mode. In other words, it won't "disable".

What version of Odin did you download? 3.07?
 
#10 Mikestony, Jun 21, 2013
I`ve been running winxp sp3 for years, & it plays well with both phones. Better than win 7 I think !
 
#11 TALONTRAX, Jun 21, 2013
Yes, 3.07. Odin can see the phone only when I'm booted up normally, not in Odin download mode.

Harry
 
#12 hdevine, Jun 21, 2013
Make sure that you don't have kies running. Either disable or uninstall it. Kies and Odin don't like each other. Also make sure nothing else is trying to connect to the phone when it is plugged in:)
 
#13 Mikestony, Jun 21, 2013
OK, I tried this again this morning, same result. I uninstalled Kies before I attempted anything. Booted normally, I can swipe down and change to "Connected as a media device" instead of "connected as installer", and I can look around on the phone from a Windows Explorer window. Odin can NOT see the phone at this time.

Then when I power off and then back on into Odin Download Mode, Odin cannot see it either. Could there be something wrong with XP? The reason that I ask that is because I have put USB sticks into this machine in the past, and XP sometimes has a difficult time seeing or accessing them.

Thanks for any ideas!
Harry
 
#14 hdevine, Jun 24, 2013
hmmm...I really don't know what else to suggest personally, except maybe uninstall Odin, then try a fresh install of ODIN.
I would suggest a different cord, but you said that your computer can communicate with your phone with no problems, so I don't think the cord is the issue.....but.....:dontknow:

Do you have another cord just to try?
 
#15 Mikestony, Jun 24, 2013
I can only think of 1 last diagnostic strategy here. First off . . . If windows xp CAN communicate wtth the device in normal "on" mode, then I don't think it's a winxp issue because any program running in the winxp envinroment will use the same drivers/software to establish communication with the device (odin in this case). Do you have access to another winxp system to try it with ??

Orr . . . Do you have another I535 to hookup to your pc (wife's or kid's phone) to determine if the problem is the pc or the actual phone ??

Just remembered . . . I had a communiation issue awhile back . . .
The fix was:
Power down the phone. Remove the battery, the sim card, & the sdcard(if you have one).Power back up & try odin again.
 
#16 TALONTRAX, Jun 24, 2013
I only have the 1 phone so I can't try another. I pulled the sim card, SD card and battery, reseated them and tried again. Same results. I guess I could try to re-download Odin and run it again, but it wasn't really an "install". Just got extracted to a temporary folder and run direct from there.

I could try and see if a co-worker could let me use their PC. I could try to put Windows 7 in a Virtual Machine (via Oracle VirtualBox) if anyone thinks that would work any better.

Thanks,
Harry
 
#17 hdevine, Jun 24, 2013
It`s got to be in the phone. If your pc communicates with the rom (phone on), it`s not the pc. Thinking about it . . . the download mode, recovery, & the rom all reside on different partitions on the device. I believe that the partition or memory area that the download mode resides in could be the issue. I imagine that there is no way to verify this, worse yet, fix it, other than a factory/hard reset of the device. :thinking:
 
#18 TALONTRAX, Jun 24, 2013
OK, so I will try to do the factory reset. I have backed up my data already so I can get that back. After I do this, and if it lets me flash and root the phone, isn't the new ROM going to go on as a factory reset anyway? I guess what I'm asking is I'd have to basically factory reset/wipe the phone to go with a custom ROM, correct?

Thanks!
Harry
 
#19 hdevine, Jun 25, 2013
If you factory reset now, yes, all your data and contacts will be wiped.
Then lets say you set your device up with your contacts and apps (before root).
If you root using this method, your data will not be wiped.

But, if you decide to flash a custom rom, then yes, your data will be wiped just like a factory reset. (but there are root apps such as Titanium Backup that will allow you to save apps/data/texts/wifi apn's/etc).

Does that answer your question? :)

By the way, I was thinking of this, have you tried a different usb port on your computer?
And don't use a usb hub of any sort.
 
#20 Mikestony, Jun 25, 2013
Yes, I have. I have a laptop at work connected to the docking station. There are 3 USB ports on the docking station, as well as 3 USB ports on the laptop itself. I've tried all 6 and got the same result. I even used my original cable that came with the phone (it was at home) and there was no change.

Thanks,
Harry
 
#21 hdevine, Jun 25, 2013
OK, I was able to get it rooted. I used another machine in our office that has Windows 2003 Server on it and Odin was able to see the device and flash what it needed. Very strange that my laptop couldn't though, but at least I have it working and have a place to do updates when necessary.

Thanks for all of the assistance!
Harry
 
#22 hdevine, Jun 25, 2013