Home Forum

Support Tethering / Mobile hotspot not working on Mobile data share plan

I have the AT&T Mobile data share plan. My understanding is that includes tethering at no additional charge (other than the data), based on the following:
I've never attempted tethering / wifi hotspot before. When I tried today, I was unsuccessful. Here are the details of my attempt:
  • Phone: Rooted AT&T S4 SGH I337 running 4.4.4.
    • I have some minor tweaks, but I don't think they should interfere
      • I have a firewall, but I Disabled it prior to attempting to tether
      • Have some bloatware frozen, but these do not include "AT&T Hot Spots", "TetheringAutomation" or "TetheringProvision"
  • I used the normal method: settings / connections /more-networks /tethering-and-wifi-hotpots.
  • ... selected "mobile hotspot" (with data on and wifi off)
    • displays "Please wait while verifying" for about 30 seconds
    • then displays "There is a temporary network problem that prevents the enablement of the Tethering function. Please retry later"
  • ... selected "USB tethering (with data on, wifi off, and usb cable plugged to computer and recognized by computer)
    • error message same as above
What do you think is going on? From googling, these messages are received when your carrier is blocking your phone. Why would AT&T block me, when I have the mobile share plan? Maybe they block rooted phones?

There are plenty of threads in the S4 section about setting up for tether, but those seem to be all about bypassing carrier restrictions when they are legitimately blocking you. I'm not wanting to go there until I understand why AT&T would be blocking me.
 

Related:

#1 electricpete, Aug 4, 2015 Last edited: Aug 4, 2015
If you have a custom recovery,I'd make a full back-up & then run the full stock/rooted ROM w/o any app freezing/deletions/etc.....see what happens.
 
#2 KOLIO, Aug 5, 2015
Thanks, that might be the right answer, but it'd take me awhile.

Anything easier to try or check?
 
#3 electricpete, Aug 5, 2015
In the meantime,I'd try to unfreeze the bloat,see if that helps.
At least you have it frozen instead of deleted. I found out the hard way once upon a time,deleted a lot of bloat w/o having a back-up.

Keep us posted...............
 
#4 KOLIO, Aug 5, 2015 Last edited by a moderator: Aug 6, 2015
Long before I would wipe my phone, I would try some of the root solutions developed for people who want to bypass legitimate tethering restrictions. Anyone has a reason to think that wouldn't work?
 
#5 electricpete, Aug 5, 2015
Thanks I'll try that.
 
#6 electricpete, Aug 5, 2015 Last edited by a moderator: Aug 6, 2015
Please keep us posted on your progress (w/the unfreezing).................
 
#7 KOLIO, Aug 5, 2015 Last edited by a moderator: Aug 6, 2015
Victory!. I disabled all my xposed modules (15 of them, listed in spoiler below), then it worked like a charm. So I'll have to selectively re-enable them in groups to narrow it down. Thanks again for the help.
  • [*]app settings

    [*]app ops xposed

    [*]boot manager

    [*]complete action plus

    [*]Heads up notifications

    [*]KitKat full SD card access

    [*]MinMinGuard

    [*]Notify Clean

    [*]PinNotif

    [*]Playstore link in app info

    [*]secure settings enhancements

    [*]swype tweaks

    [*]xblast tools

    [*]XuiMod

    [*]YouTubeAdAway
 
#8 electricpete, Aug 8, 2015
Well, problem is still solved, but explanation is not so clear.

I re-enabled all my Xposed modules, and tethering is unexpectedly still working.

So maybe three possibilities to explain things:
1 - Toggling the Xposed modules off/on changed their settings.
Does not seem likely since the modules were toggled from the framework without even going into the settings. And since re-enabling I havne't noticed any change in the behavior of my modules.​
2 - Something changed on the carrier end (after all if I read the error message literally, it said something about "temporarily unavailable")
Doesn't seem likely, but you never know.​
3 - I didn't truly have my firewall disabled.
Doesn't seem likely as I checked it several times, but you never know.
So, it may not be much help for someone who finds this thread and has the same problem. But my problem seems solved anyway.

Thanks again for the help.
 
#9 electricpete, Aug 9, 2015
Holy Xposed modules batman! :p

Just curious, you mention toggling the modules off, then on from the framework....when you toggle the module off, does that make that particular module settings back to default? Such as the Xblast module...it has a few settings in it that can be changed. If you toggle it off, then back on, do the setting reset to default?

I'm not familiar with all but 2 of the modules you list, but perhaps one module was contradicting another, then when you disabled the modules, then re-enbled them, their settings went back to default.

Does that make sense? :eek:
 
#10 Mikestony, Aug 9, 2015
Toggling xposed modules off and back on doesn't reset the settings to default...they return the same as they were before toggling (customized). But as you say if there's some type of conflict, maybe results would be unpredictable (Perhaps the order in which the modules are applied changes when you toggle them all off/on). Beats me.
 
#11 electricpete, Aug 10, 2015