Google Pixel 2 XL Forum

Problem with Bluetooth connection in car...

when trying to connect BT to car, it errors an wont connect -- see video attached


I believe pixel 1 had same issue until a hot fix was issued

anyone else experience this?


(PS posting for a friend, it's his video, I've got the regular pixel2)
 

Related:

#1 Joker718, Oct 21, 2017 Last edited: Oct 21, 2017
Maybe the Bluetooth for the car needs an update?
 
#2 pixel1killa, Oct 22, 2017
friend said that same issue occurred with pixel 1 until an update was made, however I will relay info and double check on that
 
#3 Joker718, Oct 22, 2017
The Bluetooth in my truck connects very fast and so far very reliably... However...I am not getting voice over Bluetooth features that are supposed to be working such as notifications and Google nav. I believe that some of these are an 8.0 bug and will hopefully be fixed soon. I haven't had problems with any Bluetooth devices not connecting at all.
 
#4 mrsymo, Oct 23, 2017
I have no issues with Bluetooth. Google assistant works extremely well over Bluetooth as well.
 
#5 pstellato, Oct 26, 2017
I've had issues with my P2XL but I've determined they are related to my gear S3 being connected. Not sure if your friend had a smartwatch.
 
#6 mrtull4, Oct 30, 2017
I don't have issues connecting to Bluetooth, just staying connected. My headphones will periodically disconnect and reconnect and happens in the car(usually when I'm trying to answer a call).
 
#7 kxracer823, Nov 22, 2017
I have not personally had any BT issues with either of my Pixel 2 XL's nor my OG Pixel. I have heard a few others on Reddit having issues, you may want to check over there and see if anyone found a fix.

Good luck!
 
#8 shalemail, Nov 22, 2017
I have a Gear S3 and have the same issue. Sometimes my car connects and sometimes it doesn't. From what I've read in different forums, there is a Bluetooth bug when connecting multiple devices. I'm hoping it is fixed in 8.1 since it's pretty darn annoying and more importantly, unsafe.
 
#9 conanbarb, Nov 22, 2017
I have the Moto 360 v2 and have not had issue with either the Pixel or the Pixel 2 XL.
 
#10 shalemail, Nov 22, 2017
I have also have an issue with my Bluetooth connecting to my car my pixel 2XL connects to my car Bluetooth ok, but when an incoming call comes in it doesn't play through the car speakers and I have to manually Press speaker and then back to Bluetooth before the call plays through the car speakers. I have to do this for every single call it's very irritating for some reason it does not default to the car speakers.
 
#11 alexdatainc, Dec 7, 2017
I wanted to add I previously had a Galaxy Note 5 that defaulted to the car speakers every time I never had a problem with that phone using bluetooth through my car.
 
#12 alexdatainc, Dec 7, 2017
Hi all!

Just to.let you know what has worked for me. My car is 3 series bmw coupe 2010.
First of all update to OREO 8.1

Then go to your developer mode. In developer options go down to bluetooth settings and choose the option to show bluetooth devices without name, just bt address. Choose version 1.5 or 1.6 ( try which works )
After this setup you should see initially a few addresses which will then very quickly convert i to device names.
From here its easy, just pair the phone to your car, choose your car as a trusted device.
Once you see your phone connected, feel free to set all of the above mentioned options to tgier default setting and quit developer mode.
Your phone will connect to your car in no time next time you switch on your bluetooth on your phone.
Hope this works for you guys 😁
 
#13 pinco000, Dec 15, 2017
I also have a problem with Bluetooth and car radio. When I say "OK, Google", it doesn't "ding" and it doesn't speak to me thru the car speakers, UNLESS, the music source is housed on my phone, such as Pandora. All sources in the car, such as an SD card, are not silenced and their is no sound through the car speakers. I did the "chat" routine, but it went nowhere. Any ideas?
 
#14 THF, Jan 16, 2018