LG G3 Forum

Root My G3 is Softbricked - $20 to the first person that can help me fix it!

I'm going crazy here and I need my phone to work!

I have an LG G3 on Verizon.

I rooted it and edited a part of build.prop to change the DPI which got the phone stuck in a boot loop and kept popping up "the process com.android.systemui has stopped.

I tried clearing cache

I tried booting in safe mode

I then did a factory reset

My phone boots up to the Setup Wizard screen but I am STILL getting that systemui error and a com.android.phone and I can't get any further than that screen.

I then tried to use the LG FlashTool to just wipe the entire ROM and replace it with the stock one from Verizon.

This gave me a "Model Information Check FAIL!" error but I DO have the right ROM for my phone. There's only one for the Verizon G3 as far as I can tell

This led me to realizing that there is something in the build.prop that's making LGFlashTool think the proper rom actually isn't right.

I then installed the Android SDK so I can ADB into my phone. but whenever I run "abd devices" nothing shows up in the list.

I was told USB Debugging needs to be turned on in order for this to work, I don't remember if it's turned on or not with my phone and I can't get past the Setup Wizard to edit anything. I wonder if ADB is even running properly on my phone or if these errors are stopping it?

I will gladly paypal someone $20 if they can get this working for me.
 

Related:

#1 jpf566, Sep 6, 2014
Hey jpf566, I've moved your thread over to the all-things-root area for the LG G3 in hopes the good folks in here can help you out.

Best of luck!
 
#2 scary alien, Sep 6, 2014
Did you edit the model in the build.prop also or just the DPI? Need a few more details if you have any but you may have a couple options depending on what's been done.

edit: Also need to know if you have ever installed a custom recovery after rooting.
 
#3 iowabowtech, Sep 6, 2014
Try taking the battery out to see if that helps with the system ui crashes.
At this point having usb debugging on or off does not matter.
If LG flashtool recognizes phone to tell you its wrong model number that's something. Have you installed the correct drivers to your computer? did you extract the zip for the tot and dll file? do those match your model number? did you replace the megalock.dll file? Are you sure you are in download and com port set to 41? As the moderator stated are you sure you didn't change the model number are download rom for different model number? (people make mistakes, doesn't hurt to triple check everything
If adb shell does not recognize phone then you have to force driver install. This can be found in adb setup at theunlockr.com
Its a good idea to make sure these things are ready to go BEFORE you need them.

edit: I meant usb debugging not needed for lg flashtool. abd will not work in non working phone that is having a system ui crash.
 
#4 ADRIANPG, Sep 8, 2014
Hey guys thanks for your help...it ended up being a stupid fix, I just tried flashing it on another computer and I didn't get the error? I have no idea why it worked.
 
#5 jpf566, Sep 8, 2014
yeah I have heard of trying another computer also.
 
#6 ADRIANPG, Sep 8, 2014
Try this:
The dreaded RED 2? Problem returning to stoc
 
#7 Texas501, Oct 28, 2014
Still need help?
 
#8 XmayhemreturnsX, Jun 26, 2015
Looks like he got it sorted in his last post ;)
 
#9 Mikestony, Jun 26, 2015