LG Optimus F3 Forum

Root [MetroPCS & T-Mobile] [GUIDE] Howto Root LG Optimus F3

Root

Disclaimer: rooting your phone entails risk. You may brick it, cause it to catch fire, cause it to form the first node in the Skynet network, or otherwise render it inoperable. Please read the directions carefully to ensure that nothing unexpected happens. This rooting tool is safe for the most part, but there's never any guarantees.

For a video showing the steps to root, see Galaxy S4 Build MK2 and MJ7 root instructions - YouTube
(basically the same)

This method is confirmed working with T-Mobile and MetroPC F3 after "b" and "c" updates.

Android version 4.1.2
Software version P65910b

Android version 4.1.2
Software version MS65910c

Step 1 - setting up the USB drivers
Before you try using this rooting program, you'll need to have the USB drivers installed for your phone.

The easiest way to do this is to install LG USB Driver. LGUnitedMobileDriver_S50MAN310AP22_ML_WHQL_Ver_3.10.1.exe

If you don't have the drivers working, the root installer will hang at "waiting for device..."

Step 2 - Enable USB Debugging
The second thing you must do is to enable USB debugging on your phone. Go to "Settings", "More...", then "Developer Options".
If "Developer Options" doesn't appear, then you'll need to enable it - go to "Settings", "More", "About Phone". Scroll down so the "Build Number" is visible, then tap on that several times until developer mode is enabled.

In Developer Options, make sure "USB Debugging" is checkmarked.

Make sure Media sync (MTP) is checked

That's it for the phone.

Step 3 - Unzip the saferoot.zip
saferoot.zip
Then you need to unpack the attached ZIP file somewhere onto your PC.
You should have the following when done:
- a file called "install.bat"
- a file called "install.sh"
- a folder called "tools"

Step 4 - Root your phone
Double click on the "install.bat" to run the root. It will root and reboot your phone. Once that's done, you're rooted!

Rooting on Linux and MacOS
You'll need to have the Android Debugging Bridge (adb) installed and configured and on your path. You can test that it's ready by opening a shell (Terminal) window and typing "adb shell". If you get a shell prompt on the phone, type "exit" and you're ready to go.

Open a shell window, use "cd" to change to the directory where you unpacked the zip, and type "sh ./install.sh".

Notes
Don't try to download this onto your phone and run it from there. That won't work.
Having troubles getting adb connected? There are several possible causes and solutions.
When adb first connects to your phone, it will display a dialog box reading "Allow USB debugging?"
You may need to turn on your phone to see that. Tap on the "Always allow from this computer" checkbox to enable it, and tap "OK".

There are cases where people can't get the connection working unless they toggle the USB connection type from Camera to Media and back. Perhaps that may help getting it to work.

Source: [ROOT] Saferoot: Root for VRUEMJ7, MK2, and Android 4.3 - xda-developers

Thanks to: please thank dschach who posted the method here. and please thank the original poster k1mu from xda developers.

http://androidforums.com/metropcs-t...8-guide-unbrick-unroot-lg-optimus-f3-kdz.html
http://androidforums.com/metropcs-t.../812531-guide-lg-optimus-f3-apps-sd-card.html


___________________________
[​IMG]
Support my work
 

Related:

#1 duper1, Dec 29, 2013
The link to the saferoot file isn't working
 
#2 Dark Creation, Dec 31, 2013
Use this link which appears further down in that post-
[ROOT] Saferoot: Root for VRUEMJ7, MK2, and Android 4.3 - xda-developers
There is a link in the xda thread to download the file, that link is working as of now.
 
#3 Fox Mulder, Dec 31, 2013
Link Update: saferoot.zip
 
#4 duper1, Dec 31, 2013
Ok,I've i have the lg drivers and the safe root. However, when i open the saferoot and double click runbat i get the black popup screen, it tells me to press any key to continue. I press a key then the black popup screen closes. Am i doing something wrong?
 
#5 Dark Creation, Dec 31, 2013
Did you unzip the files? It won't run from the zip, you have to extract it first. Also the phone USB mode should be in "charge only".
 
#6 Fox Mulder, Dec 31, 2013
I did it! Thanks alot bro!
 
#7 Dark Creation, Dec 31, 2013
.
 
#8 duper1, Dec 31, 2013
i have a mac how do you unzipp a file
 
#9 Franknmaria, Jan 1, 2014
i have a folder that is called saferoot in my downloads i then open it and get a folder called files a file called install.bat and a file called install.sh and their is not folder called tools.
 
#10 Franknmaria, Jan 1, 2014
No, there isn't a tool folder. However, i didn't need it. Everything was provided with saferoot. Just install the drivers so your cpu recognizes your phone, and run install.bat once extracted and you're good to go
 
#11 Dark Creation, Jan 1, 2014
I have an old macbook pro and all this down load stuff is hard for me to understand im a little slow .i dont get how to do stuff like extracting files and running them. is their a way to root with out pc, i did it on a zte by cricket it seemed so easy. Oh yeah can anybody tell me what no su bianary meen.
im sorry in advance for my ignorance
 
#12 Franknmaria, Jan 2, 2014
just follow the steps described for OS X users. Just double click a file to extract it and then follow through with using Terminal... no need to install anything else on OS X ..
 
#13 jjrx3, Jan 2, 2014
"invalid Attachment specified. This can happen for a variety of reasons-- most likely because the thread or post you are trying to view has been moved or deleted. Please return to the forum home and browse for another similiar post."

links dead..
 
#14 nyktovus, Jan 9, 2014
Get it here-
[ROOT] Saferoot: Root for VRUEMJ7, MK2, and Android 4.3 - xda-developers
(link is already posted earlier in the thread but here it is again)
 
#15 Fox Mulder, Jan 9, 2014
Worrking on Metro Pcs Optimus F3.[​IMG]
\
 
#16 baa71goat, Jan 20, 2014
I had the same issues as above at first. Installed the driver set the pc connection type to media sync and the bat stopped when it tried to verify the phone was connected. Then it hit me "DUH" you have to run it as an administrator or it can't access anything. Once I did that it worked like a charm. Hope that helps someone and the OP is corrected to mention this.

If you don't know how what I'm talking about; Right click on the .bat file and select "Run as administrator" from the context menu.
 
#17 raymccullie, Jan 22, 2014
it only shows install.sh and install
 
#18 mmc770, Jan 31, 2014
In the folder options on your PC you probably have "Hide extensions for known file types" checked. That would hide the .bat extension. If you click on "install" it should run.
 
#19 Fox Mulder, Jan 31, 2014
So, After I successfully rooted using this method ...a couple hours later my phone bricked .....so I guess over all it wasn't too successful ...anybody have any ideas why? ...my phone was the Lg Optimus F3 with virginmobile
 
#20 _ThatGuy_, Feb 4, 2014
- This post is located in the LG F3 MetroPCS and T-Mobile section of all things root. It clearly says working for MetroPCS and T-Mobile.
 
#21 duper1, Feb 17, 2014
I honestly believe that Richard Brandson and Google are spending big money to keep freelance developers at bay. I notice this Optimus F3 isn't the newest phone, so most of the info on the web goes back to mid last year and I have discovered formerly working to now be obsolete. Saferoot, motochopper, and framaroot, whether new or old, used with lg ls720 drivers or not, do not work today, 03/01/14. I even tried some Chinese root app. These don't work.

Yes, it could be me. I'm not perfect. I'm not entirely tech savvy, but following basic directions I can do. I've rooted in the past.

Can someone verify my conflicts with rooting this phone with drivers installed (LG website), debugging enabled, and MTP PC connection? Now some guy on a YouTube video says the sd card must be patitioned. Well, that I didn't do, as he is the first and only person to say that.

I really am trying to get around Android's disabling of tethering. Great difficulty.
 
#22 newpersonhere, Mar 1, 2014
I can confirm I'm having the same problem: saw the same thing about the SD card will try that this weekend.
 
#23 magicrat, Mar 7, 2014
Got it to work: only thing I did different was change to a different SD card
Now I have to figure out what I want to do with it now that it's rooted...
 
#24 magicrat, Mar 8, 2014
I just rooted with this method on my VM V6 firmware phone. Sorry but the VM forum doesn't seem to have any working roots listed besides this. motochopper didn't work. I hope it won't brick my phone like it did the other guy.
 
#25 masterchief3k, Mar 13, 2014