Samsung Galaxy S4 Forum

Support How do you delete the auto backup album from photo galery?

Can anyone tell me how you delete the backup photo album from the camera gallery on the Galaxy S4?? I disabled it in google+ & deleted the photos in there, but can not figure out how to delete them from my gallery!

 

Related:

#1 keithh1, May 21, 2013
You probably mean the instant uploads. That's the picasa web algum from Google. All you have to do is go to the website and delete the pics from there, then they will dissappear from your phone. :)
 
#2 ceva321, May 21, 2013
That has annoyed me on my GNex. Isn't it from Google+, though?
 
#3 TheyCallMeBT, May 21, 2013

I am having the same exact problem. I deleted it off my google+ account but its still on my phone and not deleting. Have you found out how to remove it?? Thanks!
-jackie
 
#4 jackiens, May 26, 2013
This doesn't actually delete the photos, but I know how you can keep them from view in the gallery. While in the gallery, hit menu and choose "Content to display". Then uncheck "Content in Picasa". That way the only pictures in the gallery are only the ones you take and of course whatever you download and such.

This drove me absolutely nuts at first.

Hope this helps! :)
 
#5 gaterie, Jun 4, 2013
I found the pics at picasa and deleted the unwanted ones (this left a few in the picasa album and updated the album cover).
The auto backup folder is still in my gallery with the offending picture as the album cover.
I've tried to add new pictures to the folder and it tells me "unsupported file".
I've looked in ES file manager and I couldn't find the folder.
I'm a photographer using my phone as my portfolio, I need to have control over my folders especially in my gallery.
Thank you in advanced.
cw
Galaxy S4
 
#6 cwgalaxy4, Jun 5, 2013
See this write-up:

android.appstorm.net/how-to/internet/how-to-remove-picasa-albums-from-your-gallery

New user so I can't post hyper links...
 
#7 matthewssawyer, Jun 5, 2013
that has been making me pull my hair out!!! thanks! That link worked!
 
#8 bradyapba, Jun 6, 2013
ok how do I get to them
 
#9 tmasker, Jun 7, 2013
Its really simple. Go to settings go to accounts then press google+ account tap on your email and delete it off your phone. That way the pictures wont be on your phone or google+ account
 
#10 adorebeba, Jun 11, 2013
if you deleted the pics from google+ and they're still showing up in your gallery, just go to settings/more/application manager
then go to ALL, find Gallery & clear the cache
:D
 
#11 deventhedude, Jun 19, 2013
[ [ Phone LG L40G; Tablet Asus TF101. Both run Android 4.0.3 ] ]

None of this works for me.

I cleared the backup album from Picasa. It's gone on line.

But even after clearing data and cache on both devices, it's still there. On both devices.
 
#12 mfwills, Jul 1, 2013
Thank you for this useful link.
It was bothering me, why some pictures still remained in the Gallery on the phone, although I deleted them from Picasa Web Albums.
All I had to do is step 2 in the link, to clean the Gallery app's cache.
Now the Auto Backup folder is updated, and doesn't contain pictures which have been removed from Picasa Web Albums.
Very simple solution.

Best regards
Egi
 
#13 Egi, Jul 8, 2013
That was so simple, and that has bugged me for a while. Thanks a bunch!!!!!
 
#14 TheyCallMeBT, Jul 9, 2013
You can delete your gallery auto back by going into settings than application Manger than go to all than find gallery than you clear data and that should work
 
#15 Melvix1, Nov 12, 2013

This really did help. It was driving me nuts for a long time.
 
#16 trevinorn, Nov 5, 2014
You go to your settings then click on application manager then go to all and scroll down to gallery then u click clear cache and clear data ... it works on most ppm but it didn't work on me..... I still have 38 pictures that won't delete
 
#17 Jazmyne2019, Jul 21, 2015
I tried it, but did not find gallery tab in scroll down, however gallery icon exists on my desktop. Please advice. Thanks.
 
#18 Ahmad Mati, Aug 4, 2015
Sorry, I find it as I was checking under "Download" instead of "All". Thanks.
 
#19 Ahmad Mati, Aug 4, 2015