Nexus 4 Forum

Support Gmail - new mail not appearing in main Inbox view

EDIT: Please see post # 3 in this thread. After experiencing a strange issue with the way in which Gmail was showing up on my Nexus, I found out about the Gmail issue outlined and documented in post # 3. This is now the primary issue which I'm facing and there is a large community of Nexus 4 users, programmers/developers and Google employees who are participating in the linked discussions and working on the issue.

Hopefully they can get this worked out soon!

Nick
 

Related:

#1 tradernik, Mar 12, 2013
Not sure if this may solve your particular issue but sometimes, Gmail gets a bit stuck and new email doesn't get instantly shown in the inbox, although you know it's due because of notification of one new email for example.

To resolve this, go to Settings / Apps / All. Find Gmail and go into the settings and clear the data and cache. This will start a new synchronization with the Google servers and should bring it better in sync.

Sent from my Nexus 7 using Tapatalk HD
 
#2 daffyduck, Mar 13, 2013
Thanks, I'll try that. However, I have since found out that this is part of a known issue with the Nexus 4 that a lot of people are dealing with. Threads on this subject, which include the participation of Google employees and Developers, can be found here, here , and here .

It's bitter irony that a device as cool as this one is having problems working with, of all things, the Gmail app. I have no need for all these social networking apps etc etc. All I need is rock solid reliability in browsing, messaging and email, and Gmail is at the centre of everything.
 
#3 tradernik, Mar 13, 2013
Have you tried using the actual email app as opposed to the Gmail app? It might be a bit more reliable?
 
#4 El Presidente, Mar 14, 2013
I haven't had any issues at all with gmail syncing on mine... And I've had it since the day it was released. Gmail is the only email I use and I use only the Gmail app.
 
#5 chrlswltrs, Mar 14, 2013
That's nice to know. There's a large community of people having this same issue and Google has acknowledged it in the thread I linked to. Have you tested the push functionality when you are at home, connected to WiFi, and you've let the phone go to sleep while connected to WiFi?

Actually, I haven't! I used the native email app to set up my Hotmail account. I will give it a try, but I have read every post in all 3 threads I linked to, and if this was a possibility, I have a feeling someone would have mentioned it. Still, it's a good idea to try.
 
#6 tradernik, Mar 15, 2013
By the way, I want to say that I called Google Nexus support and they were awesome. I told them about the troubles I'm having and they ackowledged that they had been hearing about these things. I told them that at one point, the two-finger swipe down from the top had stopped working for me and that the phone had also crashed when I was trying to add stars or 'favourite' people in my contacts list. The rep asked me a few more questions and then immediately said he was not comfortable with letting me use the handset and that he was sending me a replacement.

Blackberry could take a page out of this book. I asked Blackberry last week about their warranty policy, and they said 'We make them, we don't sell them' and told me that to get warranty repair/replacement, I had to go to the 'Point Of Sale entity'. Nice way of saying that I have to fight with whoever I bought it from if I have a defective handset.
 
#7 tradernik, Mar 15, 2013
I tried using the native email app to set up a gmail account but the setup process limited me to a minimum of 5 minutes to sync with the server. Push is absolutely required for my email exchanges with my clients which occur in real time.
 
#8 tradernik, Mar 15, 2013
Is Push enabled on the server side of your gmail account? Go to the Gmail web client, settings, Forwarding and POP/IMAP. Is POP or IMAP enabled?

Silly question, but that might be the issue.
 
#9 El Presidente, Mar 15, 2013
Naw, no question is silly at this point. It's IMAP, so yes, push is enabled and push actually works on this phone... except when it doesn't because of this issue with WiFi connectivity when the phone cannot poll the Gmail server after it goes to sleep and is awakened. Push has been working perfectly on my (mildly hated) iPhone for the past 3 years.
 
#10 tradernik, Mar 16, 2013