Samsung Galaxy S2 Forum

Support "Currently unable to download. Please try again later."

For at least a week now, whenever somebody has tried to send me a picture via text message, I have been unable to view the picture. Instead, there's download button where the picture should be, and when I click it, I get the error message in this thread's title.

I've had more than one person try to send me a pic, just to make sure the problem is with my phone. Very weird. Are there any settings I should fiddle with before calling T-Mobile?

Oh, I should mention my SGS2 is fairly new, and came from the factory with ICS already installed.

Thanks in advance for your assistance!


#1 PacificaBren, Nov 26, 2012
Hello PacificaBren :ciao:

I do very little texting so I can't offer much help. The only thing I can suggest is to try Handcent SMS and see if that helps any.
#2 Atma, Nov 26, 2012
I think I know what may be the problem!!!! I have had this problem when a picture was sent to me from the pesky iphone. I am unable to view the picture but there is a download button and guess what when I press it nothing happens.

Go ahead and do the following test - if you have a family member around you or friend that has a phone other than the apple fruit product snap a pic and send it to your self as an MMS (that should be the way people are sending it) except the iphone has some weird stuff it does with pics and the mms function really does not work.

After you receive the text there should be a thumbnail of the picture in the messaging app window (that is assuming you are using the default app). Click on the thumbnail and see if you can open the full picture. They are pretty low quality and you should see the pic but also be able to count the pixels on it.

Hope this helps - I know mms works because me and a buddy of mine that got a windows phone exchange memes all the time. :)
#3 alextop30, Nov 27, 2012

Thanks, but two of my friends have the same phone as me, on the same carrier, and I'm not able to see the pics they send me. So it's got to be something else.
#4 PacificaBren, Nov 27, 2012
I phoned T-Mobile tech support and they got my problem sorted out. I'm now reporting back for the benefit of anybody in the future who may happen to Google "Currently unable to download. Please try again later" and wind up looking at this thread.

From the home screen, click on menu/settings/more/mobile networks, then click on "Access Point Names." Once you're on the Access Point Names screen, hit your menu button and choose "Reset to default."

Then get a friend to send you an mms message with a picture in it to test whether the problem is fixed. That's what fixed it for me, anyway.
#5 PacificaBren, Nov 28, 2012

Glad you got it fixed and thanks for posting your solution. :thumbup:
#6 Atma, Nov 28, 2012
My pleasure! I'm sure I'll get more from this community than I could ever give, so I'm glad for any opportunity to contribute something useful.
#7 PacificaBren, Nov 28, 2012
I know this was an old post but thanks for the help, Even though this was not the exact method to my fix ,it gave me a good starting point for to figure it out for my G2
menu\settings\wireless and networks\mobile networks

make sure
Data enabled
Data roaming are checked

Once I did pictures downloaded without a problem
#8 ERRR09, Jun 9, 2013
Hey, that's great! I'm glad to know my post was helpful!
#9 PacificaBren, Jun 9, 2013
Where is the "menu" button? Is it that thing that looks like two pieces of paper underneath a box? When I push the two pieces of paper under a box button, it does have a "settings" option but when I push it, there's nothing like "access point names" or "mobile networks".
#10 4WDGreg, Jul 10, 2013
How do you make sure "data enabled" and "data roaming" are checked?
#11 4WDGreg, Jul 10, 2013
Yes, that's the menu button.

When you press it, you should see a stack that looks like this:

Wireless and network
Data usage

You have to click on "More..." to be able to continue. From that next screen, click on "mobile networks," and you should see the settings you're looking for.
#12 PacificaBren, Jul 10, 2013
My problem was having mobile data off because I use wifi. I guess you can't download attachments over wifi.
#13 Ste, Aug 25, 2013
Thank you for the solution!

For those people like me who had to unlock their phone, (you can unlock your phone for free with a google search) the APN disappears every time you do a factory reset. You will have to re-type the APN. Some people need to change their APN settings if they have been throttled, whatever that means.
I have AT & T service and bought a T mobile phone, so.

This is where you go to get the APN settings to type in.

[How To][Guide] Att Apn List - xda-developers
#14 JD421, Dec 1, 2013
Sorry for reopening an old thread... I tired to reset APNs but I only had one in the list and the reset button was grayed out. I poked around a bit more and discovered that my mobile network was set to global instead of LTE/CDMA. I set that, and turned on my mobille network and all the mms w/ a non-working download button reloaded correctly. I got the messages instead of a download button. I have a Note3 on Verizon. I was on my home wifi network and still did not get mms. I' not sure if switching to LTE or turning on my mobile data fixed the problem. I'd think no matter what, if I'm on wifi, i should get mms. Hope this helps someone!
#15 tjgriffin, Feb 12, 2014
Thanks so much for taking the time to come back and post this solution. Worked like a charm. Awesome that you got a tech who was knowledgeable.
#16 bannyg, Apr 12, 2014
If you do this you could get charged roaming charges when out of the coverage area. Especially important if you travel internationally. It has nothing to do with the solution to the error.
#17 isaacbro, Aug 20, 2014
I know this thread is old, but I felt obligated to provide my solution for my situation. My father-in-law bought a LG G2 Mini dual sim that only uses 3G. We updated and installed all apps needed for his job as well. Long story short, the attachments from the text service (MMS) couldn't downloaded any pictures.

What I did:

I went ahead and added a new APN into the wireless settings, such as what tjgriffin posted. I found and used these settings: (REMEMBER): Different settings apply if you're using LTE phone vs a 3G phone.

APN: but you it’s an LTE Device, use: instead
Proxy: <Leave in Blank>
Port: <Leave in Blank>
Username: <Leave in Blank>
Password: <Leave in Blank>
Server: <Leave in Blank>
MMS proxy: <Leave in Blank>
MMS port: <Leave in Blank>
MCC: 310
MNC: 260
Authentication type: <Leave in Blank>
APN type: default,supl,mms
APN Protocol: Leave it to the Default one

VOILA! It worked! Attachments went through and we were able to download the pictures! Hope this helps others. Thanks!
#18 Robo04, Jan 16, 2016
I faced same problem on Samsung Galaxy III. As per other comments , this error is mostly due to SD card. Either it's faulty or full. Mine was faulty. I downloded an App "FolderMount" and it fixed something in SD card, patched it. And Viola! I can now download any pic on WhatsApp :). If this don't work , Last option is Unmount SD card and full format. Take backup though first.
#19 aryabob, Mar 2, 2016
I do experienced the same, What I figure out on my device is that I have lots of apn configuration in my Configuration message. I requested a lot of apn settings to my carrier and I guess that's the reason why it get jammed. It is located on the message app then press the menu and there it is the configuration message. Delete it all. The APNs that you are using will not get lost, It's just a matter of deleting unwanted messages. Hope it will work for you :))))) It is really annoying to see "currently unable ....etc...." every time you use your device...
#20 Faz Leuch, May 4, 2016
My phone was doing the same, so I went to the messaging app I'm currently using "Go SMS pro" and went to settings, then click on general, when there you should see MMS click on MMS Behavior if it says "Legacy" you click it then go back to your message with the file that needs to be downloaded and tap it. After that your picture or whatever should come through with no problem.
#21 Teka, Sep 10, 2016
How do you make sure that it's LTE?
#22 Higd ty, Oct 10, 2016