Samsung Captivate Forum

Captivate USB Drivers Links Here

says server not found
 
#2 Donaldkbart, Jul 16, 2010
Thanks!
 
#3 Surfer, Jul 16, 2010
I just tested all links in my post and they all work... Which one doesn't work for you?
 
#4 maerlim, Jul 16, 2010
was my internet sorry, thank you for the links
 
#5 Donaldkbart, Jul 16, 2010
Hmm, I'm thinking this might be a good thread to be sticky. How do we go about doing that?
 
#6 maerlim, Jul 16, 2010
Request to mods. Just did it.
 
#7 t-readyroc, Jul 16, 2010
Alright, the thread is stickied or is that stuck? Either way, it is up there. Just let someone know if you guys want it taken down. :D
 
#8 OfTheDamned, Jul 16, 2010
These are only necessary if you plan to root, right?
 
#9 ardyer, Jul 16, 2010
They're necessary to use the SDK, whether you're rooting or if you just want to use ADB to side-load some apps (which you can do regardless of root).
 
#10 maerlim, Jul 16, 2010
does these work on windows 7??


Duh: I just tried it and it works on 7. Thanks for the download
 
#11 tnayrbj, Jul 18, 2010
This is taking a super long time to install...
 
#12 mesasone, Jul 18, 2010
Does that mean we can sideload without rooting? What are other benefits of rooting other than sideloading? Thanks.

Just picked up my Captivate.
 
#13 carbon3c, Jul 18, 2010
These are the wrong drivers! The correct ones from Samsung are here:

Support for Samsung Captivate? (SGH-i897) SAMSUNG
 
#14 MrTony, Jul 18, 2010
Thanks Mr. Tony worked great! Got my teathering working perfectly now.
 
#15 Ostate24, Jul 18, 2010
I can't seem to find the download for the drivers on the Samsung website. theres no download button or anything.
 
#16 xaerie, Jul 19, 2010
Are you hitting the "Software" link that's beneath the downloads tab?
 
#17 t-readyroc, Jul 19, 2010
Yeah. released July 16th, 3.74mb but no link for the download
 
#18 xaerie, Jul 19, 2010
That's odd... There's a sort of a zip file image beneath the File heading in the table for me... I just tried to attach them to this post & it failed, so I uploaded it to my Box acct. Enjoy.

**Edit - It's amazing that this file's been downloaded 334 times to date, & not a single one of the people who've downloaded it have hit the "thanks" button. No love...
 
#19 t-readyroc, Jul 19, 2010
Thank you very much. using the dev tools in my browser I found a lot of errors in trying to navigate with that zip button
 
#20 xaerie, Jul 19, 2010
will loading the usb drivers allow me to work with googles app installer with out the need for root?
 
#21 hoodtrix, Jul 19, 2010
Yes, if you just want to use adb to install apps, you don't need root, but you do need these drivers.
 
#22 maerlim, Jul 19, 2010

Using windows 7 x64 and these drivers both from samsung and posted above in first post say mtp usb driver failed insatll. Anyone help?
 
#23 jazzman09, Jul 19, 2010
Using either the drivers from the first post or the drivers from Samsung's website the samsung usb composite device installs, but the S3C6410 Android ADB and USB Mass Storage Device fail to install. I have tried with USB debugging on and off. Have set USB to mass storage on the phone. Not sure what to try now. Win7 64bit

Peter
 
#24 howudodat, Jul 19, 2010
ok, sorry to clutter this thread, found the other thread a couple of pages in http://androidforums.com/samsung-captivate/124548-windows-cant-find-captivate.html Win 7 would recognize the phone on my front USB ports, had to move it to the rear.

Peter
 
#25 howudodat, Jul 19, 2010