Samsung Galaxy S2 Skyrocket Forum

Support Cant open Gallery says "not enough space" i have free space..

hi i have just recently updated to the 4.1.2 update and ever since i have been having a weird issue.. when i tap on gallery to open my pictures it says "not enough space, delete unused items. blah blah" but i have an SD card with about 4 gigs free space, and about .5 gig for system storage but my USB storage says 11.25/11.25 and i dont know how to delete stuff. it worked fine before and i dont think it was full before the update because i was able to use every feature just fine

does anyone know how to fix this??
 

Related:

#1 unekmike, Apr 26, 2013
I got the same message, so when I tried connecting my phone to my pc as an external hd, it would never connect, even though I've done this countless times prior to my 4.1.2 upgrade.
 
#2 Sirrah, May 3, 2013
Ok, here is what I learned from talking to a Samsung tech over the phone: using Kies, when you are connected and see your phone on the right side (both internal and micro Sd card), click the folder and it will open the directory in "My Computer", allowing you to delete/move/copy files.

It works for me; I hope it works for you.
 
#3 Sirrah, May 4, 2013
I have same problem since update. Is it going to mean a hard reset?
 
#4 veddw, May 12, 2013
Mine was doing the same thing. I needed to delete some but couldn't even get into my gallery to delete some photos. So I went a different way: Apps / My Files / Images / Camera

From here you can select and delete any unnecessary photos to at least get things working again. I have a lot of videos and still shots. If you cannot live without any of yours, I don't know what to do.
 
#5 janeric1, Jul 29, 2013

Hi tried the above even freeing up the memory lower than 50 capacity, but still getting same response and not able to open the gallery.
 
#6 wizkids, Sep 23, 2013

I have the same problem. I try to open the gallery and get the message saying 'Not enough space......'. There is space on the sd card and phone memory. I found a differnet picture viewer ap called quickpic which allows me to look at pictures. But I'd rather use the gallery since this is linked directly to the camera and was faster. Can someone out there help? :mad:
 
#7 bjm188, Sep 29, 2013
I know it's been awhile since anyone has posted to this thread and it looks as if no solution was given. Here's my thing. I've had the Skyrocket since 2012. In the summer that year it fell out of my pocket on a roller coast. It was probably time to bury it and move on, but I hung onto to and ended up sending it to Samsung for repair in early 2013. It ran sluggish, but I expected that. I then did the update to 4.1.2. Then 4 months later the screen spontaneously cracked in two places. One could tell it was from under the screen. Samsung replaced the screen, for a small fee of course. That was 3 months ago. One New Year's Eve I attempted to take a screen shot and it froze. I removed the battery. When it came on I attempted the screen shot again. It said it couldn't be done. Later I took a pic. When I went to the photos app, I too could not access it. I didn't have enough space. Several other things happened and still do. I ended up looking at storage. Device storage is/was 1.97gb. It's supposed to have 16gb. It still happens. I can't pull the notifications bar down. The camera fails to respond. AT&T told me a partition was installed and my phone wasn't letting me access it. Samsung made me do a factory data reset and it didn't work. They said if the reset cleared it then it was due to a third-party app, but since the reset didn't clear it they want the fix it, for a small free of course. Has anyone come up with a solution to this problem? Could it be the update?
 
#8 dwitb, Jan 10, 2014
Solution: install SD Maid from Google Play (for free). Then run its System Cleaner.

I had the same issue myself, even after clearing up space on both SD card and internal storage, including deleting a gig or so of old thumbnails that were auto generated. I guess there is something like and "index.dat" (a Windows file that you can't delete through normal means) getting in the way somehow.

I don't know the cause. But I hope this helps everybody here.
 
#9 Billman64, Jun 10, 2014
You must delete the cache partition after you upgrade to jellybean. Enter recovery mode by turning off your phone. Press and hold volume up and down buttons and press power button untill phone vibrates once. Release power button but hold volume buttons untill recovery menu appears. Use volume down button to hi-lite "delete cache partition" and use power button to select. Make sure "reboot" is highlighted and press power button to select.
 
#10 jbest, Jul 9, 2014
I started getting the error described in the first post of this thread. I was also having trouble downloading files with Dolphin browser. The problems seemed to start around the same time, right after a Dolphin browser upgrade. I connected my Galaxy S2 with Android 4.1.2 to my PC using USB Storage mode. I right-clicked the phone USB drive icon in Windows Explorer and then clicked Properties->Tools and ran a check for disk errors. The scan identified a corrupted TunnyBrowser (Dolphin) temp file of some sort and repaired the file system error. After that, both of the problems I was having disappeared. Gallery works fine again.
 
#11 Android_user2014, Sep 13, 2014
Got the most recent Samsung exhibit a couple of months and this problem came up about a week ago. I still showed plenty of space but kept getting the device memory delete files message. After reading thru another thread on here I went in to settings - application manager went to all apps and went to gallery and disabled it. I also disabled a few factory installed apps that were useless and cleared data and cache of a few others and forced stop them. I then went back in and enabled gallery again. Works great again!
 
#12 Shlakeyd, Jun 7, 2015
 
#13 godfreydaniel, Jun 14, 2015
I'm techno challenged. I started getting the error message again. I haven't added anything, taken more pics, or downloaded any more vids or music. The message just popped up for no reason I can figure. My question is how do I know which apps are not necessary and can be disabled without any negative result?
 
#14 godfreydaniel, Jun 14, 2015
Hey guys! I've been looking for a solution: I was installing Note 4 Mini Rom for my Note 3 Neo and I tried to open Gallery, when appears a message saying "There is not enough space (*Mb) delete some files..." Bla, bla, bla...
Well, just download Int-SDCard Write Fix. (This issue comes with write protection by installing a new Rom without the right full wipes. Take care!
 
#15 Felipee, Jun 22, 2015
Hey there. Same thing happened to me and I know a way to fix this.
Download a terminal emulator and type the following codes in :
'su'(ignore the inverted commas) and hit enter.
'restorecon -v -R /data/media' (hit enter again)
This solved it for me, hope it works :)
 
#16 Akhil Krishnakumar, Oct 22, 2015
So im probably opening an old wound, but i have this problem with my galaxy express 3, and im in lollipop. I went into recovery mode and cleared the cache partitiinr, downloaded sd maid and ran system clean, and im still getting the error message. Thoughts? Anyone?
 
#17 klemmchowdah, Dec 19, 2016
So I'm not sure if this will work for everyone but when I was having this problem I went into my storage and clicked 'Miscellaneous files' which had apps that I had deleted months ago still taking up space. I deleted the ones I no longer used and the problem was immediately resolved. Good luck everyone!
 
#18 puns_and_roses, Dec 23, 2016
I used to shift few apps to the SD card or sometimes go to the application manager and go to all apps and then to gallery and disable it
 
#19 sheifa_mes, Feb 8, 2017
If AT&T is your carrier a quick fix is disabling AT&T Locker. Go to application manager and select AT&T Locker, disable and acknowledge warning. Problem solved.
 
#20 Express 3 Fix, Feb 26, 2017