Samsung Galaxy Tab Forum

Support Cannot connect on wifi... Galaxy Tab

A was surprise that last night my Galaxy Tab doesn't connect to wifi... while my Galaxy S is connected... I didn't remove anything from my Tab but all it appears is "Obtaining IP address but it doesn't connect...:(

need your help... thanks...
 

Related:

#1 ron1122, Nov 14, 2010
Did your Tab ever connect to wifi before this happened?
 
#2 ConceptVBS, Nov 15, 2010
Yes sir... and it doesn't acces wifi only at our house... but in in other places wifi can connect easily...
 
#3 ron1122, Nov 16, 2010
Perhaps you should check your settings on your router. Make sure its working on the same band, 802.11 a or b or g or n.
 
#4 ConceptVBS, Nov 17, 2010
do you have MAC address filtering set on your router?? That could be preventing it from connecting until you add teh Tab's MAC address to that table
 
#5 Legato, Nov 17, 2010
Mines doing the same thing. It connects everywhere but my house. I can even connect it to my EVO
 
#6 burley1, Nov 17, 2010
i didn't do anything now it's back to normal... can now connect at our house....
 
#7 ron1122, Nov 18, 2010

I wish:mad:
 
#8 burley1, Nov 18, 2010
same problem again..... any ideas on what to do.... i couldn't connect again.... =(
 
#9 ron1122, Nov 22, 2010
I had this issue, once, and powering off completely and turning back on the Tablet fixed it.

I'm starting to think its some sort of weird bug.

There have been cases in the past where a particular WiFi implementation isn't 100% compatible with multiple routers across the board. I had this issue with my Zune and my Verizon ActionTec router. I'd check for updated Firmware for your router and/or ping the support forums for the manufacturer?
 
#10 burningembers, Nov 22, 2010
i have a TP-Link router.... i've tried it several times but nothing happens... hope this problem could and soon... thanks for the inputs sir...
 
#11 ron1122, Nov 22, 2010
hey man, yea i have the same problem too, cant connect to my home wifi... made me go all the way down to the shop to ask for a refund.. haha. but they refused. I factory restored my tab and it was ok again... so i guess thats a solution.. cheers
 
#12 j3rMs, Nov 26, 2010
i have the same problem too. I have a TP-Link router to which my 2 laptops, iphone and recently galaxy tab are connected. when i'm out of the router range and come back, all the other devices except the galaxy tab work without any issues. in the galaxy tab, i keep getting "Obtaining IP address but it doesn't connect..."

i tried power off-on and resetting to factory default settings but did not work.
finally using the laptop, i logged into the TP-Link admin site http://192.168.1.1 and when i refresh, the galaxy tab suddenly gets connected.
now-a-days this is how i'm getting conencted to the wireless from my tab whenver i come back to home:-(
 
#13 faboo, Dec 9, 2010
i think TP-Link is not that compatible with tab.... also using tp-link at home....
 
#14 ron1122, Dec 9, 2010
Same problem here!

Sometime my Galaxy Tab will connect with Wifi at my house and sometimes it won't! This is pretty annoying. My other devices connect fine (iPod, BlackBerry, PC). I noticed the problem after I installed Norton Mobile Security. Of course I have now uninstalled Norton but am still having the same issues. I am using a FIOS router.

Anybody get this fixed?
 
#15 galaxytab, Dec 14, 2010
ok guys I got a fix for this.

The problem is that the galaxy tab is getting an IP address from your router and holding on to it. If a new device comes onto the network it will try to reassign you an IP but the galaxy tab will not allow, still wanting the old IP address.

The Fix is to create a static IP address. Go into wifi settings click menu and then advanced. Look up your dns server, gateway and netmask and set the corresponding fields in your galaxy tab settings. Make sure to also see what the IP range that your router can give (mine was 192.168.1.2 to 192.168.1.240)

Also dont forget to click use static IP address. I used 192.168.1.20 because I will never have 18 wifi devices on my network at once.

I hope this helps becuase I was banigng my head over the table for 3 days trying to fix this.

Oh and u have to turn static off when you use your wifi at another location
 
#16 MasterRy88, Dec 14, 2010
How do I look up my dns server, gateway and netmask values? Is this the drill when I have to drag my desktop over next to my router, hook up directly with ethernet cable and punch in a 192.1.1.0 type number? Is there another way to do this? And What do I do when I'm at the local McDonalds and I want to connect to their WiFi? I hope Samsung fixes this.

Thanks for the help!
 
#17 galaxytab, Dec 15, 2010

As for the dns stuff you just have to be on the network, you dont actually have to plug into the router. The USUAL thing that u would do is in your browser go to 192.168.1.1 (this is the address for all linksys routers and most other routers) Here you can usually login to your router and find all the necessary information.

Another way to do this would be to go on your windows machine. Start -> run -> cmd.

Then type ipconfig /all

This will tell you most of the same information.

As far as random places like mcDonalds I dont have a solution for this. You can go to McDonalds and connect with a windows machine and do the same ipconfig thing to get all their info and do the same thing, but that wont always work because sometimes they will hide that info or whatnot. So my understanding is thay you can connect to their wifi once and then if the IP address they try to give you changes your tab will no longer connect..

I go to college and at my school I did not have to do this. I do not know if its becuase my college assigns me a specific ip address that never changes or if its becuase they are using a different type of router. But whatever it is I have never had a problem connecting with their wifi.
 
#18 MasterRy88, Dec 15, 2010

It's not that. I use MAC address filtering, have entered the tab's address and I too have the same problem. If you search the web for android wifi diisconnect problem, it's fairly cmmon and no fix yet. I called TMobile (my povider) and all they know how to do is a factory reset or replace the unit. I've tried everything; static IP, WPS connection, removing the sim and trying to just use wifi, and other options but I still have the problem. It also appear to make wifi sleep even though I have it set to "never" and whenever I power down and back up, it turns off the wifi and turns on the mobile network! Maybe TMobile caused this trying to mess with voice (they've disabled it) and trying to force users onto their mobile network insteadof our own wifi so we're using our data plans (and they hope racking up charges for going over data limit? I had that issue with an old BB Curve where it kept disabling my wifi and reactivating their mobile network whenever I left my home, went out, and then returned home).

This is frustrating.
 
#19 barkway, Dec 19, 2010
Nope. Already tried that. Didn't work

 
#20 barkway, Dec 19, 2010
Me too........didn't work:(
 
#21 jeffff, Dec 19, 2010
OK, I just tried something.......go to the Allshare App on the Tab and connect to wifi thru there.

Low and behold, it worked!!
 
#22 jeffff, Dec 19, 2010
I tried to connect using the AllShare App and it didn't work :( I think this is the reason the Galaxy Tab Wifi-Only version never came out. Because the wifi only works intermittently. Some days the wifi will work on my router and some days it won't. It's totally random and totally annoying.

I'm not sure it's strictly a Galaxy Tab problem though. I have searched around on Google and other Android smartphones have had this same problem. Please fix this with 2.3 Gingerbread!
 
#23 galaxytab, Dec 20, 2010
Hi all ..

I have the same problem with connetion Galaxy Tab to wifi at home to TP Link wireless router ...

At work the wifi works fine but at home there is a problem.
Tab try to obtain an IP address, I can see attempts in router log, but it is not successfull.
Also other devices (iPhone, laptops) can connect without any problem ..

I tried to change SSID, change channel, change speed .. but nothing helped.

Didn't try yet to set static IP in Tab (but don't want, the wifi at work is configured different), didn't try to reset Tab ...
 
#24 Peter Salberg, Dec 23, 2010
Galaxy Tab, Froyo, Vodafone firmware P1000BUJI5.

I was connecting to my neighbor's WIFI router (he gave me the WPA password), and the first day I connected without problem.

Since then I cannot anymore connect, it always get stuck at the "Obtaining IP Adress" loop. At the same time I still can connect without problems with my laptop (ubuntu) and Nokia E71 mobile phone.

It's a brand new Galaxy Tab and I'm thinking to return it if the problem persists.
 
#25 soprano, Dec 23, 2010